ARRL

Secure Site Login

KM4FPZ

Joined: Mon, Feb 2nd 2015, 17:47 Roles: N/A Moderates: N/A

Latest Topics

Topic Created Posts Views Last Activity
Yaesu FT-2900 problem Mar 16th 2017, 00:36 4 1,314 on 17/3/17

Latest Posts

Topic Author Posted On
Yaesu FT-2900 problem KM4FPZ on 16/3/17
Thanks for the reply. The coax should be good. It is brand new lmr-400. When the problem started it was hooked up with brand new RG-8. Both cables have factory connections. Originally it was hooked up to a j-pole and that is when the problem started. Now it is hooked up to a Comet GP-3. When the problem first started, I tried the radio on both the power supply and my truck battery without any difference at all. The only constant is the radio itself since everything else has been changed. I'll go through this weekend and see if I missed something. I've been looking for an excuse to get a new rig, I may have thay excuse now. Once again, thanks for the reply.
Yaesu FT-2900 problem KM4FPZ on 16/3/17
Like the title says, I have a little 2 meter rig that is giving me fits. It turns on fine but when keying up it cycles off and right back on again. It worked fine for a while on a j-pole with SWR's around 1.4:1 or so. It started this cycling thing without warning. I've since changed antennas (Now using a Comet GP-3) and I've also tried running it from my truck battery (I normally have it hooked up to an Astron RS-20A) all with the same results. Factory reset yielded no results either. My questions are...

1) What causes this?

2) How can I test the SWR's with a radio that won't stay on long enough for the meter to tell me anything?

3) What can I do to fix it?

4) Is it worth fixing in the first place?

Any help would be greatly appreciated.

Back to Top