ARRL

Secure Site Login

tkeithlu

Joined: Sat, Oct 31st 2015, 13:06 Roles: N/A Moderates: N/A

Latest Topics

Topic Created Posts Views Last Activity
advice on tuner, please Dec 5th 2015, 22:44 2 1,236 on 5/12/15
advice on tuner, please Dec 5th 2015, 22:04 1 1,030 on 5/12/15
What's wrong? From newbie Oct 31st 2015, 13:19 5 1,335 on 1/11/15

Latest Posts

Topic Author Posted On
advice on tuner, please tkeithlu on 5/12/15
This general (/AG!) newbie has a very simple rig: a marine mobile Icom ic725, LDG 100 tuner, and 23' vertical whip. The tuner matched
4-30 mHz until I added a ceramic insulator through my steel boat, and lengthened the feed line by a couple of feet in the process. A local ham has recommended a manual tuner, which is fine with me; I'd like to know whats going on in my system rather than just being frustrated when the green light doesn't come on. Is that good advice, and would a MFJ-945-E do the job, ordo you have a better idea. Thanks. I've got a lot to learn. --Tim.
advice on tuner, please tkeithlu on 5/12/15
This general (/AG!) newbie has a very simple rig: a marine mobile Icom ic725, LDG 100 tuner, and 23' vertical whip. The tuner matched
4-30 mHz until I added a ceramic insulator through my steel boat, and lengthened the feed line by a couple of feet in the process. A local ham has recommended a manual tuner, which is fine with me; I'd like to know whats going on in my system rather than just being frustrated when the green light doesn't come on. Is that good advice, and would a MFJ-945-E do the job, ordo you have a better idea. Thanks. I've got a lot to learn. --Tim.
What's wrong? From newbie tkeithlu on 31/10/15
Nope. Holding the tuner button down longer at either the radio or the tuner gives a short tone, a long tone, three or four LED flashes at the tuner, and then "Thru." No bumps or clicks.
What's wrong? From newbie tkeithlu on 31/10/15
Holding down tune button until tones occur. I'll go try holding it down longer. Thanks.
What's wrong? From newbie tkeithlu on 31/10/15
I'm a newbie without an Elmer. My rig is an Icom 725 feeding a LDG IT-100 tuner closely connected to a Shakespeare 23' vertical on a steel boat. I've improved the radio and tuner grounds with short copper straps to the hull, and gotten rid of an antenna grounding. Reception has improved, but the antenna will not tune. It goes to "Thru" at every frequency 1.5 - 28 MHz. Any ideas? Thanks in advance. -tkeithlu

Back to Top