ARRL

TQSL Download

Download and Install TQSL 2.0.3

New TQSL 2.0.3 can be downloaded here. 

TQSL 2.0.3 is available for MS Windows (PC), Apple OS X (Mac) and Linux operating systems.

You do not have uninstall older versions of TQSL. 

TQSL 2.0.3

  • TQSL 2.0.3 for MS Windows

    Trusted QSL software is compatible with all versions of the Windows operating systems that Microsoft currently supports.
     
    Go Now

  • TQSL 2.0.3 for Apple OS X (Mac)

    Universal binary for PPC and Intel processors; OS X versions 10.4 and later.
    Go Now

  • TQSL 2.0.3 for Linux

    Linux users can build the software from the source code for the tqsllib library and the TQSL applications. (ARRL does not maintain packages for the plethora of Linux distributions. For assistance with obtaining a packaged version for your Linux distribution, contact your distribution's maintainer.)
    Go Now

TQSL 1.14

Error Messages and Solutions

Error Message:
"There is a problem with this Windows Installer package. A program
run as part of the setup did not finish as expected. Contact your
Support personnel or package vendor."

Recommended Solution:
Rename C:\Program Files\TrustedQSL\unins000.exe to
unins000.bad and re-run the 2.0 installer. It should then ignore the 1.1x.x installation and complete the upgrade. (That could be “Program Files (x86)" - wherever TQSL 1.1x.x is installed.)
 

Error Message:
Could not delete value  C:\Programs\TrustedQSL\from key Software\Microsoft\Windows\CurrentVersion\Installer\Folders.  Verify that you have sufficient access to that key, or contact your support personnel.

Recommended Solution:
This is a permission issue.
Most likely earlier TQSL version was installed "As Administrator" and now attempting to install TQSL 2.0 not "As Administrator" (which is the correct way).

Fix would be to run the uninstall for the earlier version manually "As Administrator" Then run installer for 2.0